
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="http://www.sulphurdailynews.com/content/tncms/live/" />
<meta name="keywords" content="minneapolis&ndash;saint paul, bridgett floyd, george floyd, hennepin county attorney's office, good morning america, jovanni thunstrom, justice department, wayne reyes, federal bureau of investigation" />
<meta name="news_keywords" content="minneapolis&ndash;saint paul, bridgett floyd, george floyd, hennepin county attorney's office, good morning america, jovanni thunstrom, justice department, wayne reyes, federal bureau of investigation" />
<meta name="description" content="MINNEAPOLIS (AP) &mdash; To the general public, the video of a white police officer pressing his knee into the neck of a black man prone on the street, crying out" />
<meta name="author" content="AMY FORLITI and JEFF BAENEN | Associated Press" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/8bc99180-8585-11e6-9d75-6360ac12b210.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Swift firings for Minneapolis officers in death of black man" />
<meta property="og:description" content="MINNEAPOLIS (AP) &mdash; To the general public, the video of a white police officer pressing his knee into the neck of a black man prone on the street, crying out" />
<meta property="og:site_name" content="sulphurdailynews.com" />
<meta property="og:section" content="News" />
<meta property="article:publisher" content="https://www.facebook.com/pages/Southwest-Daily-News/211763305553513" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@SulphurNews" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.242df435c56456bcb15dfd4bd0d04199.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/live/global/resources/styles/site.css?_dc=1475071709"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/jquery.calendario.de518233105200008bda079a63aa026f.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"sidebar","style":"default","path":"\/news","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"AMY FORLITI and JEFF BAENEN | Associated Press","id":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c","app":"editorial"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":223},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.caf244e2614d000b4f73058e1c610d12.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/ads/impressions.js?_dc=1590723324"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/ads/traffic.js?_dc=1590644124"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/ads/settings.js?_dc=1519931938"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1559252651"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Swift firings for Minneapolis officers in death of black man | News | sulphurdailynews.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="http://www.sulphurdailynews.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/8bc42754-8585-11e6-9d74-3f7c51cd76bc.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Swift firings for Minneapolis officers in death of black man | News | sulphurdailynews.com" href="http://www.sulphurdailynews.com/search/?f=rss&amp;t=article&amp;c=news&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" />
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            
        </head>
        <body class="app-editorial grid-sidebar blox-asset uuid-d13b8a7e-a026-11ea-a114-5bf2e9c0209c section-news type-article infinity-disabled" data-path="/news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.sulphurdailynews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=sidebar&tncms.page.style=default&tncms.page.path=%2Fnews&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=AMY+FORLITI+and+JEFF+BAENEN+%7C+Associated+Press&tncms.asset.id=d13b8a7e-a026-11ea-a114-5bf2e9c0209c&tncms.asset.app=editorial&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.ad.vendor=blox&tncms.system.render_time=223&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.sulphurdailynews.com",
  secureDomain: "sulphurdailynews.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container">

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-1306448" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1306448" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.sulphurdailynews.com/users/signup/?referer_url=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.sulphurdailynews.com/users/login/?referer_url=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.sulphurdailynews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1306448').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.sulphurdailynews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.sulphurdailynews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.sulphurdailynews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1306448').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.sulphurdailynews.com/users/logout/" id="user-logout-form-1306448"><input type="hidden" name="referer_url" value="http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a href="/eedition"  class="nav-link tnt-section-e-edition">e-Edition</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/top_stories/"  class="nav-link tnt-section-top-stories">Top Stories</a>
                                </li><li>
                                    <a href="/news/community/"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a href="/news/court_news/"  class="nav-link tnt-section-court-news">Court News</a>
                                </li><li>
                                    <a href="/news/education"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a href="/news/police_and_fire/"  class="nav-link tnt-section-police-fire">Police & Fire</a>
                                </li><li>
                                    <a href="/news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/top_stories/"  class="nav-link tnt-section-top-stories">Top Stories</a>
                                </li><li>
                                    <a href="/sports/high_school/"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a href="/sports/college/"  class="nav-link tnt-section-college">College</a>
                                </li><li>
                                    <a href="/sports/professional/"  class="nav-link tnt-section-professional">Professional</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/life"  class="nav-link tnt-section-life">Life</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/life/top_stories/"  class="nav-link tnt-section-top-stories">Top Stories</a>
                                </li><li>
                                    <a href="/life/boomers/"  class="nav-link tnt-section-boomers">Boomers</a>
                                </li><li>
                                    <a href="/life/faith/"  class="nav-link tnt-section-faith">Faith</a>
                                </li><li>
                                    <a href="/life/family"  class="nav-link tnt-section-family">Family</a>
                                </li><li>
                                    <a href="/life/food"  class="nav-link tnt-section-food">Food</a>
                                </li><li>
                                    <a href="/life/health"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a href="/life/home_and_garden/"  class="nav-link tnt-section-home-garden">Home & Garden</a>
                                </li><li>
                                    <a href="/life/pets/"  class="nav-link tnt-section-pets">Pets</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/entertainment/"  class="nav-link tnt-section-entertainment">Entertainment</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/entertainment/top_stories/"  class="nav-link tnt-section-top-stories">Top Stories</a>
                                </li><li>
                                    <a href="/entertainment/celebrity_news/"  class="nav-link tnt-section-celebrity-news">Celebrity News</a>
                                </li><li>
                                    <a href="/entertainment/movies"  class="nav-link tnt-section-movies">Movies</a>
                                </li><li>
                                    <a href="/entertainment/music"  class="nav-link tnt-section-music">Music</a>
                                </li><li>
                                    <a href="/entertainment/tv_guide/"  class="nav-link tnt-section-tv-guide">TV Guide</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/top_stories/"  class="nav-link tnt-section-top-stories">Top Stories</a>
                                </li><li>
                                    <a href="/opinion/columns/"  class="nav-link tnt-section-columns">Columns</a>
                                </li><li>
                                    <a href="/opinion/editorials"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/letters"  class="nav-link tnt-section-letters">Letters</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/photo_galleries"  class="nav-link tnt-section-photos">Photos</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/video_gallery"  class="nav-link tnt-section-videos">Videos</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-1306444" class="tncms-block hidden-md hidden-lg"><section id="block-1306444" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1306444" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1306444" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-1306444-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1306444-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1306444-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1306444').submit();
        return false;
    });

    $('#site-search-1306444').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1306444 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1306444 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1306444-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1306447" class="tncms-block"><div id="user-controls-1306447" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.sulphurdailynews.com/users/signup/?referer_url=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.sulphurdailynews.com/users/login/?referer_url=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.sulphurdailynews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1306447').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.sulphurdailynews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.sulphurdailynews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.sulphurdailynews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1306447').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.sulphurdailynews.com/users/logout/" id="user-logout-form-1306447"><input type="hidden" name="referer_url" value="http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1306445" class="tncms-block"><div class="follow-links-1306445 pull-right">
    
    <section id="block-1306445" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/pages/Southwest-Daily-News/211763305553513" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SulphurNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.sulphurdailynews.com",
  "sameAs" : ["https://www.facebook.com/pages/Southwest-Daily-News/211763305553513","http://twitter.com/SulphurNews/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1306367" class="tncms-block a"><section id="block-1306367" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/9af28cac-8585-11e6-9ec7-8789fe72bcff.png?resize=200%2C59 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/9af28cac-8585-11e6-9ec7-8789fe72bcff.png?resize=300%2C88 300w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/9af28cac-8585-11e6-9ec7-8789fe72bcff.png?resize=400%2C118 400w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/9af28cac-8585-11e6-9ec7-8789fe72bcff.png?resize=540%2C159 540w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/9af28cac-8585-11e6-9ec7-8789fe72bcff.png?resize=750%2C221 750w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/9af28cac-8585-11e6-9ec7-8789fe72bcff.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1306449" class="tncms-block"><div id="weather-1306449" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=70663" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">71&deg;</span>
                    
                        <span class="cond">Clear <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="70663"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1306449 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Sulphur, LA
                                
                                 <small>(70663)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Partly cloudy. A stray shower or thunderstorm is possible. Low 66F. Winds light and variable..</p>
                            <h5>Tonight</h5>
                            <p>Partly cloudy. A stray shower or thunderstorm is possible. Low 66F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: May 28, 2020 @ 10:50 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=70663"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1306443" class="tncms-block"><section id="block-1306443" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1306443" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1306443" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-1306443-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1306443-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1306443-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1306443').submit();
        return false;
    });

    $('#site-search-1306443').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1306443 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1306443 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1306443-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1306440" class="tncms-block"><section id="block-1306440" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/bae7f84e-8585-11e6-9007-8fd87a451ded.png?resize=200%2C46 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/bae7f84e-8585-11e6-9007-8fd87a451ded.png?resize=300%2C69 300w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/bae7f84e-8585-11e6-9007-8fd87a451ded.png?resize=400%2C92 400w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/bae7f84e-8585-11e6-9007-8fd87a451ded.png?resize=540%2C124 540w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/bae7f84e-8585-11e6-9007-8fd87a451ded.png?resize=750%2C172 750w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/bae7f84e-8585-11e6-9007-8fd87a451ded.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/eedition" >
                    <span class="nav-label">e-Edition</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-top-stories"  href="/news/top_stories/" >
                    <span class="nav-label">Top Stories</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/news/community/" >
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-court-news"  href="/news/court_news/" >
                    <span class="nav-label">Court News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-education"  href="/news/education" >
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link  tnt-section-police-fire"  href="/news/police_and_fire/" >
                    <span class="nav-label">Police & Fire</span>
                </a></li><li>
                <a class="nav-link  tnt-section-state-news"  href="/news/state_news/" >
                    <span class="nav-label">State News</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-top-stories"  href="/sports/top_stories/" >
                    <span class="nav-label">Top Stories</span>
                </a></li><li>
                <a class="nav-link  tnt-section-high-school"  href="/sports/high_school/" >
                    <span class="nav-label">High School</span>
                </a></li><li>
                <a class="nav-link  tnt-section-college"  href="/sports/college/" >
                    <span class="nav-label">College</span>
                </a></li><li>
                <a class="nav-link  tnt-section-professional"  href="/sports/professional/" >
                    <span class="nav-label">Professional</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-life"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/life" >
                    <span class="nav-label">Life</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-top-stories"  href="/life/top_stories/" >
                    <span class="nav-label">Top Stories</span>
                </a></li><li>
                <a class="nav-link  tnt-section-boomers"  href="/life/boomers/" >
                    <span class="nav-label">Boomers</span>
                </a></li><li>
                <a class="nav-link  tnt-section-faith"  href="/life/faith/" >
                    <span class="nav-label">Faith</span>
                </a></li><li>
                <a class="nav-link  tnt-section-family"  href="/life/family" >
                    <span class="nav-label">Family</span>
                </a></li><li>
                <a class="nav-link  tnt-section-food"  href="/life/food" >
                    <span class="nav-label">Food</span>
                </a></li><li>
                <a class="nav-link  tnt-section-health"  href="/life/health" >
                    <span class="nav-label">Health</span>
                </a></li><li>
                <a class="nav-link  tnt-section-home-garden"  href="/life/home_and_garden/" >
                    <span class="nav-label">Home & Garden</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pets"  href="/life/pets/" >
                    <span class="nav-label">Pets</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-entertainment"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-top-stories"  href="/entertainment/top_stories/" >
                    <span class="nav-label">Top Stories</span>
                </a></li><li>
                <a class="nav-link  tnt-section-celebrity-news"  href="/entertainment/celebrity_news/" >
                    <span class="nav-label">Celebrity News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-movies"  href="/entertainment/movies" >
                    <span class="nav-label">Movies</span>
                </a></li><li>
                <a class="nav-link  tnt-section-music"  href="/entertainment/music" >
                    <span class="nav-label">Music</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tv-guide"  href="/entertainment/tv_guide/" >
                    <span class="nav-label">TV Guide</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-top-stories"  href="/opinion/top_stories/" >
                    <span class="nav-label">Top Stories</span>
                </a></li><li>
                <a class="nav-link  tnt-section-columns"  href="/opinion/columns/" >
                    <span class="nav-label">Columns</span>
                </a></li><li>
                <a class="nav-link  tnt-section-editorials"  href="/opinion/editorials" >
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link  tnt-section-letters"  href="/opinion/letters" >
                    <span class="nav-label">Letters</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-photos"  href="/multimedia/photo_galleries" >
                    <span class="nav-label">Photos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-videos"  href="/multimedia/video_gallery" >
                    <span class="nav-label">Videos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds" >
                    <span class="nav-label">Classifieds</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1306308" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1306309" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="asset article-default"  data-url="http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/8bc99180-8585-11e6-9d75-6360ac12b210.jpg">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="sulphurdailynews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" />
    <style>
                .asset-paging .direction {
                    color: #1c49ff;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"http:\/\/www.sulphurdailynews.com\/tncms\/search\/mlt\/?origin=d13b8a7e-a026-11ea-a114-5bf2e9c0209c&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="asset-paging">
                <div id="paging-prev-d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="paging-link prev offset"></div>
                <div id="paging-next-d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Swift firings for Minneapolis officers in death of black man
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">AMY FORLITI and JEFF BAENEN | Associated Press</span></li>
        
        
            <li class="visible-print">
        <time datetime="2020-05-27T09:31:00-05:00" class="tnt-date asset-date text-muted">
            May 27, 2020
        </time>
    </li>
            <li class="hidden-print">
        <time datetime="2020-05-27T09:31:00-05:00" class="tnt-date asset-date text-muted">May 27, 2020</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-05-27T09:31:00-05:00">
    <meta itemprop="datePublished" content="2020-05-27T09:31:00-05:00">
    <meta itemprop="dateModified" content="2020-05-27T09:31:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Swift%20firings%20for%20Minneapolis%20officers%20in%20death%20of%20black%20man&via=SulphurNews&url=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.sulphurdailynews.com/tncms/asset/editorial/d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsulphurdailynews.com%5D%20Swift%20firings%20for%20Minneapolis%20officers%20in%20death%20of%20black%20man&body=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
                <div class="row">
                    
    
    <div id="sidebar-col" class="col-md-3 hidden-xs hidden-sm hidden-print">
        <div id="sidebar"><div id="tncms-region-global-sidebar-top" class="tncms-region "></div><div id="tncms-region-global-sidebar-bottom" class="tncms-region "><div id="tncms-block-1306328" class="tncms-block"><section id="block-1306328" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1306328 ">
        <div class="block-title-inner">
            <h4>
                
                Multimedia
                
            </h4>
        </div>
    </div></div><div class="card-grid   card-img-md card-compact">
        
        
            <div class=" ">
        
        <div class="  ">
                 
                                
                    <article id="card-summary-1306328-49a86a80-4dbc-11ea-8aa7-27e4b1b92e28" class="clearfix card summary has-image image-top inherit  tnt-section-sports">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-49a86a80-4dbc-11ea-8aa7-27e4b1b92e28 media-preview collection-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/sports/sdn-photos-sulphur-beats-barbe-to-win-share-of-district-title/collection_49a86a80-4dbc-11ea-8aa7-27e4b1b92e28.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="SDN PHOTOS: Sulphur beats Barbe to win share of district title"
                            class="img-responsive lazyload full"
                            width="1152"
                            height="864"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/6/e6/6e606882-4dbc-11ea-8eb5-37962cb3cfd4/5e4434a4e644e.image.jpg?crop=1152%2C864%2C0%2C467&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/6/e6/6e606882-4dbc-11ea-8eb5-37962cb3cfd4/5e4434a4e644e.image.jpg?crop=1152%2C864%2C0%2C467&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/6/e6/6e606882-4dbc-11ea-8eb5-37962cb3cfd4/5e4434a4e644e.image.jpg?crop=1152%2C864%2C0%2C467&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/6/e6/6e606882-4dbc-11ea-8eb5-37962cb3cfd4/5e4434a4e644e.image.jpg?crop=1152%2C864%2C0%2C467&resize=540%2C405&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/6/e6/6e606882-4dbc-11ea-8eb5-37962cb3cfd4/5e4434a4e644e.image.jpg?crop=1152%2C864%2C0%2C467&resize=750%2C563&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/6/e6/6e606882-4dbc-11ea-8eb5-37962cb3cfd4/5e4434a4e644e.image.jpg?crop=1152%2C864%2C0%2C467&resize=1152%2C864&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/sdn-photos-sulphur-beats-barbe-to-win-share-of-district-title/collection_49a86a80-4dbc-11ea-8aa7-27e4b1b92e28.html" class="tnt-asset-link">
        

        
            SDN PHOTOS: Sulphur beats Barbe to win share of district title</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
            
        <div class="  ">
                 
                                
                    <article id="card-summary-1306328-d2860630-dd70-11e9-bc17-6f1fc79927c2" class="clearfix card summary has-image image-top inherit  tnt-section-multimedia">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-d2860630-dd70-11e9-bc17-6f1fc79927c2 media-preview collection-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/multimedia/sdn-photos-sulphur-27-lagrange-25/collection_d2860630-dd70-11e9-bc17-6f1fc79927c2.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="SDN PHOTOS: Sulphur 27, LaGrange 25"
                            class="img-responsive lazyload full"
                            width="1287"
                            height="965"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/78/178e0188-dd71-11e9-a254-c77204ce1e3d/5d87ce9cbeee4.image.jpg?crop=1287%2C965%2C0%2C321&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/78/178e0188-dd71-11e9-a254-c77204ce1e3d/5d87ce9cbeee4.image.jpg?crop=1287%2C965%2C0%2C321&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/78/178e0188-dd71-11e9-a254-c77204ce1e3d/5d87ce9cbeee4.image.jpg?crop=1287%2C965%2C0%2C321&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/78/178e0188-dd71-11e9-a254-c77204ce1e3d/5d87ce9cbeee4.image.jpg?crop=1287%2C965%2C0%2C321&resize=540%2C405&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/78/178e0188-dd71-11e9-a254-c77204ce1e3d/5d87ce9cbeee4.image.jpg?crop=1287%2C965%2C0%2C321&resize=750%2C563&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/78/178e0188-dd71-11e9-a254-c77204ce1e3d/5d87ce9cbeee4.image.jpg?crop=1287%2C965%2C0%2C321&resize=1200%2C900&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/78/178e0188-dd71-11e9-a254-c77204ce1e3d/5d87ce9cbeee4.image.jpg?crop=1287%2C965%2C0%2C321&resize=1287%2C965&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/multimedia/sdn-photos-sulphur-27-lagrange-25/collection_d2860630-dd70-11e9-bc17-6f1fc79927c2.html" class="tnt-asset-link">
        

        
            SDN PHOTOS: Sulphur 27, LaGrange 25</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
            
        <div class="  ">
                 
                                
                    <article id="card-summary-1306328-08a5ee30-d7e8-11e9-af78-538894a3a818" class="clearfix card summary has-image image-top inherit  tnt-section-sports">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-08a5ee30-d7e8-11e9-af78-538894a3a818 media-preview collection-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/sports/sdn-photos-sam-houston-50-lagrange-14-week-2/collection_08a5ee30-d7e8-11e9-af78-538894a3a818.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="SDN PHOTOS: Sam Houston 50, LaGrange 14, Week 2"
                            class="img-responsive lazyload full"
                            width="1609"
                            height="1207"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/7a/47af7830-d7e8-11e9-b14d-6f045c7a8a7a/5d7e8598a3b19.image.jpg?crop=1609%2C1207%2C0%2C40&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/7a/47af7830-d7e8-11e9-b14d-6f045c7a8a7a/5d7e8598a3b19.image.jpg?crop=1609%2C1207%2C0%2C40&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/7a/47af7830-d7e8-11e9-b14d-6f045c7a8a7a/5d7e8598a3b19.image.jpg?crop=1609%2C1207%2C0%2C40&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/7a/47af7830-d7e8-11e9-b14d-6f045c7a8a7a/5d7e8598a3b19.image.jpg?crop=1609%2C1207%2C0%2C40&resize=540%2C405&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/7a/47af7830-d7e8-11e9-b14d-6f045c7a8a7a/5d7e8598a3b19.image.jpg?crop=1609%2C1207%2C0%2C40&resize=750%2C563&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/7a/47af7830-d7e8-11e9-b14d-6f045c7a8a7a/5d7e8598a3b19.image.jpg?crop=1609%2C1207%2C0%2C40&resize=1200%2C900&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/7a/47af7830-d7e8-11e9-b14d-6f045c7a8a7a/5d7e8598a3b19.image.jpg?crop=1609%2C1207%2C0%2C40&resize=1609%2C1207&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/sdn-photos-sam-houston-50-lagrange-14-week-2/collection_08a5ee30-d7e8-11e9-af78-538894a3a818.html" class="tnt-asset-link">
        

        
            SDN PHOTOS: Sam Houston 50, LaGrange 14, Week 2</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
            
        <div class="  last-grid-item">
                 
                                
                    <article id="card-summary-1306328-1e9a6ac0-d33a-11e9-b2e9-53ad32d45ae9" class="clearfix card summary has-image image-top inherit  tnt-section-multimedia">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-1e9a6ac0-d33a-11e9-b2e9-53ad32d45ae9 media-preview collection-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/multimedia/sdn-photos-week-1-lc-college-prep-21-sulphur-18/collection_1e9a6ac0-d33a-11e9-b2e9-53ad32d45ae9.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="SDN Photos: Week 1: LC College Prep 21, Sulphur 18"
                            class="img-responsive lazyload full"
                            width="1287"
                            height="965"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/5e/55e27d6a-d33a-11e9-826b-5f7c0dc35940/5d76abc763515.image.jpg?crop=1287%2C965%2C0%2C321&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/5e/55e27d6a-d33a-11e9-826b-5f7c0dc35940/5d76abc763515.image.jpg?crop=1287%2C965%2C0%2C321&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/5e/55e27d6a-d33a-11e9-826b-5f7c0dc35940/5d76abc763515.image.jpg?crop=1287%2C965%2C0%2C321&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/5e/55e27d6a-d33a-11e9-826b-5f7c0dc35940/5d76abc763515.image.jpg?crop=1287%2C965%2C0%2C321&resize=540%2C405&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/5e/55e27d6a-d33a-11e9-826b-5f7c0dc35940/5d76abc763515.image.jpg?crop=1287%2C965%2C0%2C321&resize=750%2C563&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/5e/55e27d6a-d33a-11e9-826b-5f7c0dc35940/5d76abc763515.image.jpg?crop=1287%2C965%2C0%2C321&resize=1200%2C900&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/5e/55e27d6a-d33a-11e9-826b-5f7c0dc35940/5d76abc763515.image.jpg?crop=1287%2C965%2C0%2C321&resize=1287%2C965&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/multimedia/sdn-photos-week-1-lc-college-prep-21-sulphur-18/collection_1e9a6ac0-d33a-11e9-b2e9-53ad32d45ae9.html" class="tnt-asset-link">
        

        
            SDN Photos: Week 1: LC College Prep 21, Sulphur 18</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
            
        
        
        
        
        </div>
        </div></section></div></div></div>
    </div>
    <style>
        #sidebar {
            z-index: 1;
        }
        #sidebar.affix-top {
            position: static!important;
            margin-top:0px;
        }
        #sidebar.affix {
            position: fixed!important;
            
                top: 25px;
            
         }
     </style>
    
        <script>
            $('#sidebar').width($('#sidebar-col').width());
            window.setTimeout(affixSidebar, 1000);
            $( window ).resize(function() {
                $('#sidebar').width($('#sidebar-col').width());
                affixSidebar();
            });
            function affixSidebar() {
                var sBottom = $(document).height() - ($('#tncms-region-global-container-bottom').offset().top - 40);
                $('#sidebar').affix({
                    offset:{
                        top: function() {
                            return (this.top = $('#sidebar-col').offset().top )
                        },
                        bottom: function () {
                            return (this.bottom = sBottom)
                        }
                    }
                });
            }
        </script>
    

                    <div class="col-md-9">
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="d13b8a7e-a026-11ea-a114-5bf2e9c0209c">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Swift%20firings%20for%20Minneapolis%20officers%20in%20death%20of%20black%20man&via=SulphurNews&url=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.sulphurdailynews.com/tncms/asset/editorial/d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsulphurdailynews.com%5D%20Swift%20firings%20for%20Minneapolis%20officers%20in%20death%20of%20black%20man&body=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-d13b8a7e-a026-11ea-a114-5bf2e9c0209c-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="d13b8a7e-a026-11ea-a114-5bf2e9c0209c" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="save-list-d13b8a7e-a026-11ea-a114-5bf2e9c0209c-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="d13b8a7e-a026-11ea-a114-5bf2e9c0209c" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>MINNEAPOLIS (AP) — To the general public, the video of a white police officer pressing his knee into the neck of a black man prone on the street, crying out for help until he finally stopped moving, was horrifying.</p><p>Four officers were fired a day after George Floyd's death, a stunning and swift move by the Minneapolis chief with the mayor's full backing. But despite their dismissal, whether the incident will be considered criminal, or even excessive force, is a more complicated question that will likely take months to investigate.</p><p>The officers were dismissed soon after a bystander's video taken outside a south Minneapolis grocery store Monday night showed an officer kneeling on the handcuffed man's neck, even after he pleaded that he could not breathe and stopped moving. Floyd's death prompted protests Tuesday, with thousands taking to the streets at the intersection where he died.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Many protesters marched more than 2 miles (3.2 kilometers) to the police precinct station in that part of the city, with some damaging the building's windows and squad cars and spraying graffiti. Police in riot gear eventually confronted them with tear gas and projectiles, with tense skirmishes stretching late into the evening.</p><p>Bridgett Floyd told NBC's "Today" show in an interview Wednesday morning that the officers involved in her brother's death should be charged with murder because "that's exactly what they did." She said she hadn't watched the bystander's video, but told ABC's "Good Morning America" that "I don't understand how someone could possibly let an individual go out like that."</p><p>Mayor Jacob Frey announced the firings on Twitter, saying: "This is the right call."</p><p>The FBI and state law enforcement were investigating Floyd's death, which immediately drew comparisons to the case of Eric Garner, an unarmed black man who died in 2014 in New York after he was placed in a chokehold by police and pleaded for his life, saying he could not breathe.</p><p>But in the Garner case, local prosecutors, the NYPD's internal affairs unit, and the Justice Department all finished investigations into the case before the officer was ultimately fired. Garner's family and activists spent years begging for the officer to be removed.</p><p>The officers in the Minneapolis incident haven't even been publicly identified, though one defense attorney has confirmed he is representing Derek Chauvin, the officer seen with his knee on Floyd's neck. The attorney, Tom Kelly, declined to comment further.</p><p>The police union asked the public to wait for the investigation to take its course and not to "rush to judgment and immediately condemn our officers." Messages left with the union after the firings were not returned.</p><p>During Tuesday's protests, some chanted and carried banners that read, "I can't breathe" and "Jail killer KKKops." And some stacked shopping carts to make a barricade at a Target store across the street from the station.</p><p>Police Chief Medaria Arradondo said the department would conduct a full internal investigation, and prosecutors will decide whether to file criminal charges against the officers involved. The Hennepin County Attorney's Office said it was "shocked and saddened" by the video and pledged to handle the case fairly. Part of that investigation will likely focus on the intent of the officers, whether they meant to harm Floyd or whether it was a death that happened in the course of police work. The FBI was investigating whether the officers willfully deprived Floyd of his civil rights.</p><p>News accounts show Chauvin was one of six officers who fired their weapons in the 2006 death of Wayne Reyes, who police said pointed a sawed-off shotgun at officers after stabbing two people. Chauvin also shot and wounded a man in 2008 during a struggle after Chauvin and his partner responded to a reported domestic assault. Police did not immediately respond to a request for Chauvin's service record.</p><p>In Minneapolis, kneeling on a suspect's neck is allowed under the department's use-of-force policy for officers who have received training in how to compress a neck without applying direct pressure to the airway. It is considered a "non-deadly force option," according to the department's policy handbook.</p><p>A chokehold is considered a deadly force option and involves someone obstructing the airway. According to the department's use-of-force policy, officers are to use only an amount of force necessary that would be objectively reasonable.</p><p>But two use-of-force experts told The Associated Press that the officer clearly restrained the man too long, noting that the man was under control and no longer fighting. Andrew Scott, a former Boca Raton, Florida, police chief who now testifies as an expert witness in use-of-force cases, called Floyd's death "a combination of not being trained properly or disregarding their training."</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>"He couldn't move. He was telling them he couldn't breathe, and they ignored him," Scott said. "I can't even describe it. It was difficult to watch."</p><p>In a post on his Facebook page, the mayor, who is white, apologized Tuesday to the black community for the officer's treatment of Floyd, 46, who worked security at a restaurant.</p><p>"Being Black in America should not be a death sentence. For five minutes, we watched a white officer press his knee into a Black man's neck. Five minutes. When you hear someone calling for help, you're supposed to help. This officer failed in the most basic, human sense," Frey posted.</p><p>Police said the man matched the description of a suspect in a forgery case at a grocery store, and that he resisted arrest.</p><p>The video starts with the man on the ground, and does not show what happened in the moments prior. The unidentified officer is kneeling on his neck, ignoring his pleas. "Please, please, please, I can't breathe. Please, man," said Floyd, who has his face against the pavement.</p><p>Even in the coronavirus pandemic that has killed nearly 100,000 people in the U.S. and prompted police departments around the country to change how they're doing work, the officers in the video aren't wearing masks. In some cities, low-level arrests such as attempted forgery are skipped right now.</p><p>Floyd also moans. One of the officers tells him to "relax." Floyd calls for his mother and says: "My stomach hurts, my neck hurts, everything hurts ... I can't breathe." As bystanders shout their concern, one officer says, "He's talking, so he's breathing."</p><p>But Floyd slowly becomes motionless under the officer's restraint. The officer does not remove his knee until the man is loaded onto a gurney by paramedics.</p><p>Several witnesses had gathered on a nearby sidewalk, some recording the scene on their phones. The bystanders become increasingly agitated. One man yells repeatedly. "He's not responsive right now!" Two witnesses, including one woman who said she was a Minneapolis firefighter, yell at the officers to check the man's pulse. "Check his pulse right now and tell me what it is!" she said.</p><p>At one point, an officer says: "Don't do drugs, guys." And one man yells, "Don't do drugs, bro? What is that? What do you think this is?"</p><p>The Hennepin County medical examiner identified Floyd but said the cause of death was pending.</p><p>Floyd had worked security for five years at a restaurant called Conga Latin Bistro and rented a home from the restaurant's owner, Jovanni Thunstrom.</p><p>He was "a good friend, person and a good tenant," the restaurateur told the Star Tribune. "He was family. His co-workers and friends loved him."</p><p>Ben Crump, a prominent civil rights and personal injury attorney, said he had been hired by Floyd's family.</p><p>The death came amid outrage over the death of Ahmaud Arbery, who was fatally shot Feb. 23 in Georgia after a white father and son pursued the 25-year-old black man they had spotted running in their subdivision. More than two months passed before charges were brought. Crump also represents Arbery's father.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Swift%20firings%20for%20Minneapolis%20officers%20in%20death%20of%20black%20man&via=SulphurNews&url=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.sulphurdailynews.com/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.sulphurdailynews.com/tncms/asset/editorial/d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsulphurdailynews.com%5D%20Swift%20firings%20for%20Minneapolis%20officers%20in%20death%20of%20black%20man&body=http%3A%2F%2Fwww.sulphurdailynews.com%2Fnews%2Fswift-firings-for-minneapolis-officers-in-death-of-black-man%2Farticle_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/swift-firings-for-minneapolis-officers-in-death-of-black-man/article_d13b8a7e-a026-11ea-a114-5bf2e9c0209c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d13b8a7e-a026-11ea-a114-5bf2e9c0209c"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-d13b8a7e-a026-11ea-a114-5bf2e9c0209c-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="d13b8a7e-a026-11ea-a114-5bf2e9c0209c" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="d13b8a7e-a026-11ea-a114-5bf2e9c0209c" class="save-list-d13b8a7e-a026-11ea-a114-5bf2e9c0209c-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="d13b8a7e-a026-11ea-a114-5bf2e9c0209c" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22minneapolis%E2%80%93saint%20paul%22#tncms-source=keyword" class="tag-minneapolis–saint-paul label label-default" >Minneapolis–saint Paul</a>
            </li> <li>
                <a href="/search/?k=%22bridgett%20floyd%22#tncms-source=keyword" class="tag-bridgett-floyd label label-default" >Bridgett Floyd</a>
            </li> <li>
                <a href="/search/?k=%22george%20floyd%22#tncms-source=keyword" class="tag-george-floyd label label-default" >George Floyd</a>
            </li> <li>
                <a href="/search/?k=%22hennepin%20county%20attorney%27s%20office%22#tncms-source=keyword" class="tag-hennepin-county-attorneys-office label label-default" >Hennepin County Attorney's Office</a>
            </li> <li>
                <a href="/search/?k=%22good%20morning%20america%22#tncms-source=keyword" class="tag-good-morning-america label label-default" >Good Morning America</a>
            </li> <li>
                <a href="/search/?k=%22jovanni%20thunstrom%22#tncms-source=keyword" class="tag-jovanni-thunstrom label label-default" >Jovanni Thunstrom</a>
            </li> <li>
                <a href="/search/?k=%22justice%20department%22#tncms-source=keyword" class="tag-justice-department label label-default" >Justice Department</a>
            </li> <li>
                <a href="/search/?k=%22wayne%20reyes%22#tncms-source=keyword" class="tag-wayne-reyes label label-default" >Wayne Reyes</a>
            </li> <li>
                <a href="/search/?k=%22federal%20bureau%20of%20investigation%22#tncms-source=keyword" class="tag-federal-bureau-of-investigation label label-default" >Federal Bureau Of Investigation</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("814eb089-f8b4-4f96-b70d-67e791b10427");
        var apiKey = "DKGDKQMXH5RJCHRBRDXD";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-814eb089-f8b4-4f96-b70d-67e791b10427';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div>

                    <div class="asset-comments hidden-print"></div></div>
            </div>

            
                    </div>
                </div>
            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1306368" class="tncms-block"><section id="block-1306368" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1306368 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1306368" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1306368" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1306368" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1306368" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1306368" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/life/marque-it-s-important-to-know-information-about-covid-19-tests/article_79f3d008-9c3b-11ea-acb9-0781fc7528bc.html">Marque: It’s important to know information about COVID-19 tests</a></li><li><a href="/news/today-in-history-amelia-earhart-begins-flight-across-atlantic-in-1932/article_4c959b72-9aa7-11ea-9615-8fc4d83639cc.html">Today in History: Amelia Earhart begins flight across Atlantic in 1932</a></li><li><a href="/sports/carol-turner-to-take-over-shs-girls-basketball-team/article_1a001c00-97aa-11ea-9c3b-3f9370ee7d8e.html">Carol Turner to take over SHS girls basketball team</a></li><li><a href="/news/sulphur-man-arrested-for-kidnapping-incident-at-local-business/article_5bbc7a06-8a5a-11ea-b025-57a6df1294c1.html">Sulphur man arrested for kidnapping incident at local business</a></li><li><a href="/news/healthy-pigs-being-killed-as-meatpacking-backlog-hits-farms/article_843c5c88-8bdd-11ea-a2c2-df602da7bdbf.html">Healthy pigs being killed as meatpacking backlog hits farms</a></li><li><a href="/news/eat-in-restaurants-return-as-louisiana-eases-restrictions/article_c69fad9e-96bb-11ea-af78-f74ef6788c03.html">Eat-in restaurants return as Louisiana eases restrictions</a></li><li><a href="/news/at-least-2-louisiana-parishes-going-against-gov-reopening/article_c119faa8-8bc3-11ea-a575-1ff06b22d298.html">At least 2 Louisiana parishes going against gov, reopening</a></li></ul></div>
        
        
            <div id="images-1306368" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/water-plant-construction/image_4bd09304-8bc0-11ea-9f7d-7b23e869a7f8.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Water Plant Construction"
                            class="img-responsive lazyload full"
                            width="959"
                            height="959"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/bd/4bd09304-8bc0-11ea-9f7d-7b23e869a7f8/5eac40634d865.image.jpg?crop=959%2C959%2C330%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1306368" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/sports/professional/mount-olympus-titan-joe-thomas-vs-matt-chan---the-titan-games/youtube_94a46962-ec5e-5af0-85b0-032a92e46a39.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Mount Olympus: Titan Joe Thomas vs. Matt Chan - The Titan Games"
                            class="img-responsive lazyload full"
                            width="360"
                            height="360"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/9/4a/94a46962-ec5e-5af0-85b0-032a92e46a39/5ecd98d3c7b4e.preview.jpg?crop=360%2C360%2C60%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/sports/professional/mount-olympus-titan-joe-thomas-vs-matt-chan---the-titan-games/youtube_1738e225-483e-5aeb-b04c-42c683f9dba6.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Mount Olympus: Titan Joe Thomas vs. Matt Chan - The Titan Games"
                            class="img-responsive lazyload full"
                            width="360"
                            height="360"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/1/73/1738e225-483e-5aeb-b04c-42c683f9dba6/5ecd9231953a7.preview.jpg?crop=360%2C360%2C60%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/see-giant-3d-wave-sweep-over-seouls-gangnam-district/video_b104aeb5-a3f5-5b49-9904-f67f1ac1fcb4.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="See giant 3D wave sweep over Seoul's Gangnam District"
                            class="img-responsive lazyload full"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/b/10/b104aeb5-a3f5-5b49-9904-f67f1ac1fcb4/5ec70bc69f08b.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/life/pets/135-pound-mastiff-becomes-obsessed-with-a-tiny-kitten-the-dodo-odd-couples/video_e03e4263-d598-544b-8be3-8174c5223e51.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="135-Pound Mastiff Becomes Obsessed With A Tiny Kitten  | The Dodo Odd Couples"
                            class="img-responsive lazyload full"
                            width="720"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/e/03/e03e4263-d598-544b-8be3-8174c5223e51/5ecd79589a97b.preview.jpg?crop=720%2C720%2C280%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/cnns-natasha-chen-describes-beachgoers-racist-taunt/video_51f7adb2-47a9-596c-be6b-d6f3fb1e325f.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="CNN's Natasha Chen describes beachgoer's racist taunt"
                            class="img-responsive lazyload full"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/5/1f/51f7adb2-47a9-596c-be6b-d6f3fb1e325f/5ecaeec86d595.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/joe-biden-says-voters-aint-black-if-they-support-trump/video_b00487e0-a1a2-5b79-adc6-4e143bc59ba4.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Joe Biden says voters 'ain't black' if they support Trump"
                            class="img-responsive lazyload full"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/b/00/b00487e0-a1a2-5b79-adc6-4e143bc59ba4/5ec8562b76be1.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/cnn-reporter-describes-chaos-at-looted-target/video_8aa188b0-5dd5-5ec5-ac0e-de9c70ad7cf6.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="CNN reporter describes 'chaos' at looted Target"
                            class="img-responsive lazyload full"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/8/aa/8aa188b0-5dd5-5ec5-ac0e-de9c70ad7cf6/5ecf6c9830015.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/video-shows-packed-memorial-day-weekend-pool-party/video_0c4a9b67-23b7-5007-9c42-836e573160e1.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Video shows packed Memorial Day weekend pool party"
                            class="img-responsive lazyload full"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/0/c4/0c4a9b67-23b7-5007-9c42-836e573160e1/5ecac808a674d.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/aerial-video-shows-holiday-crowd-in-daytona-beach/video_dd5c30dc-1244-508e-827c-612ffdd43027.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Aerial video shows holiday crowd in Daytona Beach"
                            class="img-responsive lazyload full"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/d/d5/dd5c30dc-1244-508e-827c-612ffdd43027/5ecb202b6c41b.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/video-shows-minneapolis-officer-kneeling-on-black-mans-neck/video_49e2f3b3-236a-5a0b-8f5f-ac9e6b057504.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Video shows Minneapolis officer kneeling on black man's neck"
                            class="img-responsive lazyload full"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/editorial/4/9e/49e2f3b3-236a-5a0b-8f5f-ac9e6b057504/5ecf03375ee22.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
            <div id="commented-1306368" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><p class="no-results text-muted">Sorry, there are no recent results for popular commented articles.</p></div>
        
    </div>
</div></section></div><div id="tncms-block-1306861" class="tncms-block"><section id="block-1306861" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-1306861 ">
        <div class="block-title-inner">
            <h4>
                
                Calendar
                
            </h4>
        </div>
    </div></div>
<a class="url-template" href="/calendar/"></a>



<div class="fc-calendar-wrap card" data-squery="max-width:260px=squery-260">
    <div class="fc-inner">
        <div class="fc-header">
            <nav>
                <span class="fc-prev">
                    <i class="fas tnt-chevron-left"></i>
                </span>
                <span class="fc-next">
                    <i class="fas tnt-chevron-right"></i>
                </span>
            </nav>
            <h3 class="fc-month">&#8203;</h3>
            <h4 class="fc-year">&#8203;</h4>
        </div>
        <div id="calendar-1306861" class="fc-calendar-container"></div>
        
            <div class="fc-foot">
                <div class="fc-foot-item">
                    <a href="/calendar/">Browse</a>
                </div>
                <div class="fc-foot-item">
                    <a href="/calendar/search/?l=25&unrolled=1&s=start_time&sd=asc&d1=2020-05-28&d2=2020-05-28&f=html">Today's events</a>
                </div>
                <div class="fc-foot-item">
                    <a href="https://www.sulphurdailynews.com/users/admin/calendar/">Submit</a>
                </div>
                <div class="clearfix"></div>
            </div>
        
    </div>
</div>

</section></div><div id="tncms-block-1306319" class="tncms-block"></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1306351" class="tncms-block"></div><div id="tncms-block-1306442" class="tncms-block"><section id="block-1306442" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1306442 ">
        <div class="block-title-inner">
            <h4>
                
                Latest e-Edition
                
            </h4>
        </div>
    </div></div>
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-ccc06e07-c3b8-5749-a6eb-4fabe49c3cec" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-ccc06e07-c3b8-5749-a6eb-4fabe49c3cec media-preview edition-asset" data-aspect=""><figure class="photo layout-vertical letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/eedition/southwest-daily-news/edition_ccc06e07-c3b8-5749-a6eb-4fabe49c3cec.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Southwest Daily News"
                            class="img-responsive lazyload full"
                            width="300"
                            height="563"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/eedition/0/c3/0c318f06-d201-5f43-a33d-68213d829851/5a6a7edd4d744.preview-300.jpg?resize=200%2C375 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/assets/v3/eedition/0/c3/0c318f06-d201-5f43-a33d-68213d829851/5a6a7edd4d744.preview-300.jpg?resize=300%2C563 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/southwest-daily-news/edition_ccc06e07-c3b8-5749-a6eb-4fabe49c3cec.html" class="tnt-asset-link">
        

        
            Southwest Daily News</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
    </section></div><div id="tncms-block-1306352" class="tncms-block"><section id="block-1306352" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1306352 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/stock_market">
                
                Stocks
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class="tradingview-widget-container">
    <div class="tradingview-widget-container__widget"></div>
    <div class="tradingview-widget-copyright">
        <a href="https://www.tradingview.com" rel="noopener" target="_blank">
            <span class="blue-text">Market Data</span> by TradingView
        </a>
    </div>
    <script src="https://s3.tradingview.com/external-embedding/embed-widget-market-overview.js" async>{"whitelabel":true,"locale":"en","width":"100%","height":"660","plotLineColorGrowing":"rgba(60, 188, 152, 1)","plotLineColorFalling":"rgba(255, 74, 104, 1)","gridLineColor":"rgba(233, 233, 234, 1)","scaleFontColor":"rgba(218, 221, 224, 1)","belowLineFillColorGrowing":"rgba(60, 188, 152, 0.05)","belowLineFillColorFalling":"rgba(255, 74, 104, 0.05)","tabs":[{"title":"Equities","symbols":[{"d":"S&P 500","s":"OANDA:SPX500USD"},{"d":"Shanghai Composite","s":"INDEX:XLY0"},{"d":"Dow 30","s":"FOREXCOM:DJI"},{"d":"Nikkei 225","s":"INDEX:NKY"},{"d":"Apple","s":"NASDAQ:AAPL"},{"d":"Google","s":"NASDAQ:GOOG"}]},{"title":"Commodities","symbols":[{"d":"E-Mini S&P","s":"CME_MINI:ES1!"},{"d":"Euro","s":"CME:E61!"},{"d":"Gold","s":"COMEX:GC1!"},{"d":"Crude Oil","s":"NYMEX:CL1!"},{"d":"Natural Gas","s":"NYMEX:NG1!"},{"d":"Corn","s":"CBOT:ZC1!"}]},{"title":"Bonds","symbols":[{"d":"US 2YR","s":"CBOT:TUZ2019"},{"d":"US 10YR","s":"CBOT:TYZ2019"},{"d":"US 30YR","s":"CBOT:USZ2019"},{"d":"Euro Bund","s":"EUREX:GG1!"},{"d":"Euro BTP","s":"EUREX:II1!"},{"d":"Euro BOBL","s":"EUREX:HR1!"}]},{"title":"Forex","symbols":[{"d":"EURUSD","s":"FX:EURUSD"},{"d":"GBPUSD","s":"FX:GBPUSD"},{"d":"USDJPY","s":"FX:USDJPY"},{"d":"USDCHF","s":"FX:USDCHF"},{"d":"AUDUSD","s":"FX:AUDUSD"},{"d":"USDCAD","s":"FX:USDCAD"}]}],"largeChartUrl":"http:\/\/www.sulphurdailynews.com\/stock_market"}</script>
    </div></section></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1306310" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1306311" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/sulphurdailynews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1306436" class="tncms-block"><section id="block-1306436" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1306436 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-life"  href="/life" >
                    <span class="nav-label">Life</span>
                </a></li><li>
                <a class="nav-link  tnt-section-entertainment"  href="/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-multimedia"  href="/multimedia/" >
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features" >
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1306359" class="tncms-block"><section id="block-1306359" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1306359 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search" >
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1306441" class="tncms-block padding-bottom"><section id="block-1306441" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/2cd46d0c-8586-11e6-9cd8-2375e33ca164.png?resize=200%2C59 200w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/2cd46d0c-8586-11e6-9cd8-2375e33ca164.png?resize=300%2C89 300w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/2cd46d0c-8586-11e6-9cd8-2375e33ca164.png?resize=400%2C118 400w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/2cd46d0c-8586-11e6-9cd8-2375e33ca164.png?resize=540%2C160 540w, https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/content/tncms/custom/image/2cd46d0c-8586-11e6-9cd8-2375e33ca164.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-1306438" class="tncms-block"><section id="block-1306438" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1306438 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>sulphurdailynews.com</strong><br>
    120 S. Huntington Street<br>
    Sulphur, LA 70663
    <br>
    
        <strong>Phone:</strong> (337) 527-7075<br>
        <strong>Email:</strong> <a href="mailto:btrahan@sulphurdailynews.com">btrahan@sulphurdailynews.com</a><br>
    
</address></section></div><div id="tncms-block-1306446" class="tncms-block padding-bottom"><div class="follow-links-1306446 default">
    
    <section id="block-1306446" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/pages/Southwest-Daily-News/211763305553513" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SulphurNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.sulphurdailynews.com",
  "sameAs" : ["https://www.facebook.com/pages/Southwest-Daily-News/211763305553513","http://twitter.com/SulphurNews/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1306363" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1306363"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">sulphurdailynews.com</a>, 120 S. Huntington Street Sulphur, LA</small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("d13b8a7e-a026-11ea-a114-5bf2e9c0209c")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/sulphurdailynews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.calendario.7b513d925fce875220017f8d5a8055a0.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
        var aChecked = [],
            urlParams = '/search/?l=25&unrolled=1&s=start_time&sd=asc&f=html',

            $wrapper = $( '#block-1306861 .fc-inner' ),
            $calendar = $( '#calendar-1306861' ),
            cal = $calendar.calendario({
                displayWeekAbbr: true,
                startIn: 0,
                onDayClick: function( $el, $contentEl, dateProperties ) {
                    window.location = $('#block-1306861 .url-template').attr('href') + urlParams + '&d1=' + $el.find('.fc-date').data('date') + '&d2=' + $el.find('.fc-date').data('date');
                }
            }),
            $month = $( '#block-1306861 .fc-month' ).html( cal.getMonthName() ),
            $year = $( '#block-1306861 .fc-year' ).html( cal.getYear() );


        $('#block-1306861 .fc-next').on('click', function() {
            cal.gotoNextMonth(updateMonthYear);
        });
        $('#block-1306861 .fc-prev').on('click', function() {
            cal.gotoPreviousMonth(updateMonthYear);
        });
        function updateMonthYear(){
            $month.html(cal.getMonthName());
            $year.html(cal.getYear());
            fetchDays();
        }
        function fetchDays(){
            if( aChecked.indexOf(cal.getYear() + '-' + cal.getMonth()) == -1 ){
                $.ajax({
                    type: 'GET',
                    dataType: 'json',
                    url: $('#block-1306861 .url-template').attr('href') + '/search/?year='+cal.getYear()+'&month='+cal.getMonth()+'&fmt=json',
                    cache: true,
                    success: function(data) {
                        $.each(data, function(index, value){
                            if(value.result.numEvents > 0){
                                sMonth = value.result.month.toString();
                                if(sMonth.length < 2){ sMonth = '0'+sMonth }
                                sDay = value.result.day.toString();
                                if(sDay.length < 2){ sDay = '0'+sDay }
                                sString = sMonth + '-' + sDay + '-' + value.result.year;

                                oNumEvents = {};

                                var iOneDot = 1,
                                    iTwoDots = 2,
                                    iThreeDots = 3;

                                oNumEvents[sString] = '<div class="fc-data-item">';
                                if( value.result.numEvents > 0 && value.result.numEvents < iOneDot+1 ){
                                    oNumEvents[sString] += '<i class="fas tnt-circle"></i> ';
                                }else if( value.result.numEvents > iOneDot && value.result.numEvents < iTwoDots+1 ){
                                    oNumEvents[sString] += '<i class="fas tnt-circle"></i> <i class="fas tnt-circle"></i>';
                                }else if( value.result.numEvents > iTwoDots ){
                                    oNumEvents[sString] += '<i class="fas tnt-circle"></i> <i class="fas tnt-circle"></i> <i class="fas tnt-circle"></i>';
                                }
                                oNumEvents[sString] += '</div>';

                                cal.setData(oNumEvents);
                            }
                        });

                        if( aChecked.indexOf(cal.getYear() + '-' + cal.getMonth()) == -1 ){
                            aChecked.push(cal.getYear() + '-' + cal.getMonth());
                        }
                    },
                    error: function(response) {
                        __tnt.log(response.status);
                    }
                });
            }
        }
        fetchDays();
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script></body>
</html>